
Creating flowcharts in Visio

Flowcharts are easy to create in Visio, which provides flexibility to link to 
other flowcharts as well as to the documents used int eh described pro-
cess.

This tutorial covers the following topics:

Creating a flowchart 

Basic flowchart shapes 
To drag shapes to the drawing pane 
To connect shapes with connectors
To use a decision diamond
To add more shapes 
Remember to save the document regularly.

Improving the layout of a flowchart

To change the size of shapes 
To move a shape to a new position
To select more than one shape at a time
To glue connectors dynamical
To align shapes

Adding text and a logo to the page 

To add a title to the top of the page
To create a background page for this and other flowcharts
To link a background to a page
To save as a template

Creating links to other pages and documents

Saving the document in other formats

The Help section in Visio is excellent. Use it to get further into the many 
nooks and cranies that Visio offers!
Bonnie Yelverton - January 12, 2003



Creating flowcharts in Visio
Creating a flowchart
When you open Visio, create a new Basic Flowchart.. 
The screen that opens shows a drawing pane and a 
library of shapes that you can use to create the flow-
chart.

In this tutorial, you  learn  to create a very basic flwo-
chart, which will teach you most of the things you 
need to get started. After that, you can experiment 
with the other shapes, backgrounds nad borders, as 
well as other diagram types as you need them.

Basic flowchart shapes

The screen shot to the left show the library of basic 
flowchart shapes. When you hold your mouse over 
one of the shapes, you see a call-out with an explana-
tion of how it is used. The circled shapes are the ones 
you will probably use most often.

Every flowchart 
starts and ends 
with a terminator, 
which you see here 
with its call-out.

To drag shapes to the drawing pane
1 To start the flowchart, drag the Terminator over to 

the drawing pane, a little down from the top and 
center of the page.

2 Drag a Process shape into the pane, a little under 
the terminator.

3 Double click the Terminator and type in the 
name of the procedure.

4 Double click the Process box and write the first 
process as a Command sentence: “Do this.”

You can change the font family, size and color from 
the toolbar at the top, just as in WORD.
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Creating flowcharts in Visio
To connect shapes with connectors

Notice that a selected shape has small green boxes, 
called handles, at its edges. Drag on the handles to 
change the dimensions and size of the shape.

When the shape is not selected, 
the handles become blue x’es, 
called collectors. If you do not see 
them, select Connection Points in 
the View menu.

1 On the toolbar, click the connector 
tool. The cursor looks like the picture 
at the right.

2 Click the lower blue connection point 
on the Terminator. A red box appears 
around the connection point to show that t is 
“glued” to it.

3 Drag the line to the topmost connection point 
on the Process box to create the connector.

To use a decision diamond

Decision diamond boxes are used if the flowchart 
branches in two different directions. The text in the 
box should be a question that can be answered with 
yes or no, or two other simple answers. it has 2 con-
nectors leading from it to the two option processes. 
The answers yes and no are written on the connectors. 
Sometimes te no connector leads back to a previous 
process to start over again.

1 Drag a decision box to a position under the pro-
cess box.

2 Connect the 2 boxes.
3 Drag 2 process boxes to either side of the deci-

sion box and connect them.
4 Double click the connectors and type yes and no 

in the text box that appears.
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Creating flowcharts in Visio
To add more shapes

Add more shapes to the flowchart to represent the 
process.

1 If a process produces a document, use the Docu-
ment shape.

2 If it results in a computer registration, use a data 
shape.

3 Always end all options of the flowchart with a 
terminator.

4 If the process moves on to another procedure, 
end it with a terrminator with the name of the 
next procedure.

5 Annotation shape is actually a text box. Connect 
its line to a box, drag it into position and write a 
comment to the box.

6 The line-curve connector creates curved con-
necting lines, but they do not have the dynamic 
features of the regular connetor. (See “To glue 
connectors dynamically” on page 6.)

Remember to save the document 
regularly.

It is saved initially as a Visio .vsd file, which can only be 
accessed through Visio.

To enjoy the full functionality of a Visio document, it 
must be viewed in either Visio itself or the new Visio 
Viewer. You can download the viewer from the 
Microsoft download center (search for Visio) at: 
http://office.microsoft.com/downloads/2002/
vViewer.aspx. 

When you have completed the document, you can 
save it in other formats. (See “Saving the document in 
other formats” on page 11.)
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Creating flowcharts in Visio
Improving the layout of a flowchart
When you have added a number of shapes to the flwo-
chart and connected them, some of them will not be 
aligned properly, or boxes may be the wrong size.

To change the size of shapes
1 Click a shape to select it. Click and drag a green 

handle to stretch or shrink the box.
2 Drag from a corner to change both dimensions 

at once.
3 To keep the same proportions, hold the Shift key 

down while you drag.

To move a shape to a new position
1 Click a shape to select it, or select several as 

described below.
2 Hold the cursor over the selected shape, but not 

at an edge, so that the cursor becomes white.
3 Drag the shape or group of shapes to the new 

position.

To select more than 
one shape at a time
1 Using the pointer tool, drag 

a square around the shapes 
to be moved.

2 When you release the cursor, the selected shapes 
have green or blue handles. The one with the 
blue handles is the first to be selected, and is the 
considered the dominant shape when you align 
shapes. (See “To align shapes” on page 7.)
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Creating flowcharts in Visio
To glue connectors dynamically

When you move shapes, the connectors stay glued to 
them. However, their positions may not be appropri-
ate any more. When you glue them dynamically, they 
move around to the most appropriate connection 
points.

1 Select a connector by clicking it.
2 Drag one end of the connector into the shape. 

The entire shape gets a heavy red outline to indi-
cate that it is connected dynamically.

3 Repeat with the other end.

Now see what happens when you move one of the 
boxes in relation to the others.

The Snap & Glue dialogue box on the Tools menu 
gives you a number of options to try.
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To align shapes

When you add shapes to the flowchart and start 
changing their sizes and positions, they will inevitably 
become unaligned, which is very obvious when con-
nectors are no longer straight lines.

Instead of trying to keep shapes aligned by dragging 
them, you can do this more precisely using the align-
ing tools from the Tools menu. (Or use F8).

1 Select the shape to be aligned
2 Select the type of alignment 
3 Click OK.

The shapes are aligned to the dominant shape (the one 
with the blue handles, which was selected first.)

The Tools Menu also has a tool to distribute shapes, 
so that they all have the same distance fromeach other. 
This is done about the same way as algining shapes.
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Creating flowcharts in Visio
Adding text and a logo to the page

To add a title to the top of the page
1 Click the Text Tool on the toolbar.
2 Using the text-cursor, draw a text box at the top 

of the page where you want the title.
3 Type the title and format it with the usual for-

matting tools.

Use text boxes whereever you need text on the page.

There are also a couple of good shapes in the flow-
chart library for comments. Try these as well.

To create a background page for this 
and other flowcharts.
1 At the bottom of the drawing pane, right click on 

the Page 1 tab.
2 Rename the page to the name of this process.
3 Right-click again and select Insert new page.

4 Select Background, type a name and click OK.
5 On the Insert menu, select Picture, and browse to 

the logo or other picture. Click OK.
6 Posistion and resize 

the logo as needed.
7 Add any background 

text in a text box.

You can use this background 
for all the flowcharts you 
create.
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Creating flowcharts in Visio
To link a background to a page
1 In the File menu, select Page Setup.

2 On the Page Properties tab, click the little arrow 
to the right of the Background box, and select 
the Background page you want to use.

3 Do this each time you create a new page in the 
flowchart.

To save as a template.

Save the document first as a template if you will be 
using the same set-up often.
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Creating flowcharts in Visio
Creating links to other pages and documents
If your flow chart gets too big, you can extend it on 
several pages. For example, you can link from a termi-
nator box that represents another procedure to that 
procedure, or from a document shape to the actual 
document file.

1 Create the page or document you want to link to.
2 Select the shape you want to link from.
3 In the Insert menu, select Hyperlink (or use the 

shortcut Ctrl+K.)

You can have several links from the same shape.

1 Click New to add each new link.
2 To link to another page in the same flowchart 

document, browse in the Sub-address box, and 
select the page.

3 To link to an external document, browse in the 
Address box.

4 Click OK when you have added all the hyperlinks 
you need.

Access the links by right-clicking the shape to select a 
link.

If you create an html document from the flowchart, 
you will be able to click on the shape to access the link.

Here is the flowchart created during this tutorial.
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Saving the document in other formats
You can save the flowchart as a graphic to be used in 
another document, or even as a html webpage.The 
Save As option on the File menu provides for many 
different formats.

To use the picture in a webpage, save it as either .gif or 
.png. Use .tif for print documents. If you have 
included photos in the flowchart, a .jpg file may be 
smaller. 

If you want to use the flowchart as a webpage, for 
example in an Intranet,:

1 Click HTML Files
2 The box suggests using VML as the graphics for-

mat if all the users have Internet Explorer 5.) (as 
in an Intranet). Use .png isntead of .gif other-
wise.

3 Select the pages to be saved. Do not select the 
background page. It comes automatically.

4 The completed webpage has a navigator box at 
the bottom. External links are accessed by click-
ing a box.

Visio products and prices

On the next page is  information about the 2 Visio 
products available, Standard and Professional. You can 
find a lot of information and demos, as well as order a 
30-day trial version from the Microsoft website at: 
http://www.microsoft.com/office/visio/
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Features Visio 
Standard 

Visio 
Professional 

Intelligent SmartShapes® symbols 
  

Drag-and-drop diagramming 
  

Microsoft Office look and feel 
  

Custom properties for shapes 
  

Property reporting 
  

Microsoft Visual Basic® for Applications 6.3 
  

Block diagrams 
  

Flowcharts 
  

Organization charts 
  

Timelines and calendars 
  

Sales and marketing visuals 
  

Directional maps 
  

Basic office layouts 
  

Web site maps    

Software/database diagramming and reverse 
engineering 

   

Engineering drawings    

Building, space, and floor plans    

Logical network diagrams    

Directory services diagrams    

 

Microsoft Office 
Product 

New User Price ¹ Upgrade Price ¹ 

Visio Standard 2002 $199 US $99.95 US 

Visio Professional 2002 $499 US $249 US 
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